Problems with Biblio module


  • Question

1. I think you should change the setting in the Biblio style templates so that they show all authors, rather than the current settings of x-numbers, then et al. Most often faculty are the last author, so their name often will not show up in the listing. This is the setting to change:

function biblio_style_vancouver_author_options() {
$author_options = array(
'BetweenAuthorsDelimStandard' => ', ',
'BetweenAuthorsDelimLastAuthor' => ', ',
'AuthorsInitialsDelimFirstAuthor' => ' ',
'AuthorsInitialsDelimStandard' => ' ',
'betweenInitialsDelim' => '',
'initialsBeforeAuthorFirstAuthor' => FALSE,
'initialsBeforeAuthorStandard' => FALSE,
'numberOfInitialsToKeep' => 2,
'shortenGivenNames' => TRUE,
'numberOfAuthorsTriggeringEtAl' => 6,
'includeNumberOfAuthors' => 6,
'customStringAfterFirstAuthors' => ', et al.',
'encodeHTML' => TRUE

2. I've tried repeatedly to add a new field to the Biblio module (a Boolean checkbox to exclude certain files) and when I save the field I get the redirect message instead ("Add URL redirect from this page to another location"), with the result that I can't add a new field. This seriously undermines the usefulness of the module.

Add URL redirect from this page to another location


Have you tried using the CiteProc Style Manager (admin/config/content/biblio/citeproc/styles)? I'm looking to understand that feature better.

Regarding your second question, what steps are you taking? Maybe a permissions issue?